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3D Cell Explorers
Exporting data from STEVE for Data Processing

General Objective
The goal of this document is to present simple ways to export Refractive Index data 
generated by the 3D Cell Explorer (STEVE) into Excel to perform data calculations.
These methods can be extended to any other scientific application and will allow you to work 
in a quantitative way on the Refractive Index data distribution maps generated by STEVE.

In this document, we are using Fiji (ImageJ), an open source platform to process the RI 
information. We are presenting only few Fiji basic commands that help in this process, but 
many other alternatives can be defined with more advanced tools.
The data sets used in these procedures are for illustration only, meaning that the RI 
information provided are just for information.

Nanolive is actively developing more advanced technics to process RI datasets. 
Please do not hesitate to contact us for more advanced needs.
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How to export tomographic RI data  for data processing ?
Tools & Installation

Install Fiji (ImageJ).
This open source software package can 
be found here:
https://imagej.net/Fiji/Downloads (1)

Once installed, when Fiji is launched a 
tool bar is visible on the PC desktop
(2).

1
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STEVE 
Export Data in Tiff

From STEVE, Export the RI data in a .tiff 
format. Either use the export button or 
the File> Export command.
In the Export dialog box :
Select RI Volume
Select Tiff format
Select a folder and define a filename
Click OK

Note: the exported Tiff file is made of 
96 stacked  layers, one layer per STEVE 
tomographic slice.
STEVE layers are numbered from -47 
to +48. Tiff layers are numbered from 
0 to 96.
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Fiji
Import a Tiff file for scientific analysis

In Fiji, Open the exported .tiff file with
the File> Open command.
Or drag and drop the file directly in the 
box below the Fiji tool bar
(red rectangle below)

A new Fiji window displays the first layer 
of the TIFF file  (1)

Note: moving the slider at the bottom of
the window allows to visualize the 
different layers in the TIFF file, the layer 
reference is displayed in the upper left 
corner, here layers 48 and layer 56.

1 2
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Fiji
Export/Import a raw file (volume) for scientific analysis

In STEVE, Export the RI volume in raw 
format (1).

In Fiji, Open the exported .raw file with
the File> Open command.
Or drag and drop the file directly in the 
box below the Fiji tool bar
(red rectangle below)

A new “Fiji Import>Raw” pops-up (2), 
Fill  the following import parameters:
IMAGE TYPE: 32-bit Rel
WIDTH 52
HEIGHT 512
OFFSET TO FIRST IMAGE 0
NUMBER OF IMAGES 96
GAP BETWEEN IMAGES 0
Select LITTLE-ENDIAN BYTE ORDER

1

2

Ti

Tiff
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Fiji
Improve the Brightness/Contrast for a better visualization

Before After

1. Run the command Image > Adjust > Brightness/Contrast

This operation allows to improve the visualization in term of Brightness and Contrast by adjusting the image histogram. 
Please note that this operation do not modify the RI values inside the image, it makes the image just looking better.

2. A window B&C appears, then click on “Auto”. Do NOT
click on “Apply” that will modify the data in the image.
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Fiji
Reading RI values with mouse cursor

The Refractive Index values can be 
visualized by moving  the mouse cursor 
over the image.
The RI value is displayed in the display 
window of  the Fiji tool bar (see red 
rectangle)
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Fiji
Display RI Data Histogram

Run the command Analyze > Histogram 
(1)
A pop-up window histogram is showing 
up (2) to adjust histogram settings (bins, 
min, max…). 
Keep default values and click on “OK”, 
the histogram is displayed (3).

Note1: the histogram is calculated based
on the RI values of the current layer, the
layer displayed and active (here 56).

Note2: the focus plane is often defined
in STEVE as the slice number 0 
corresponding to the Tiff layer 48. 
Please consider that based on your 
experiment and samples, 
Tiff layers below 48 might be not relevant
in term of data analysis.

1
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Fiji
Import RI Data histogram in Excel

From the histogram window, click on 
List (1) .
A pop-up window is showing up (2) with 
all the RI data values.
Save the RI values distribution in a text
file, by running the File > “Save as“
command. And import the text file in 
Excel.
Or directly click in the Histogram window, 
use the keyboard shortcut CTRL-A to 
select all RI values, then  copy 
(shortcut CTRL-C) and paste directly in 
an Excel spreadsheet (shortcut 
CTRL-V ).
Then create the suitable graph for your 
application (3)

32

1
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FIJI
Export RI Data to Excel

The process to import a RI histogram in Excel has been described in Slide 12.

If it is needed to import all the RI values of a Tiff image in Excel, we provide two alternative 
methods:
The first one, slide 14, is the simplest. It allows to export the file in text format and to copy it 
to Excel. With this method RI data are rounded during the text export.
The second method, slides 15,16,17, is an evolution of the first one and avoid this rounding 
effect, so you can get the exact values as they are in the RI file.
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Fiji
Export RI Data to Excel (rounded method)

Load  a Tiff file, Run the command 
File > Save as > Text Image (1) and save 
the file.

Open the text file, select all data 
(shortcut CTRL-A), copy (CTRL-C) and 
paste (CTRL-V) the text in Excel (3).

Note1: please note that the X,Y
coordinates in the image in the upper left 
Corner and start at 0,0.

Note2: the RI values are rounded when
they are saved in text format, meaning
that the value 1.3375 will be changed
in 1.338. To avoid this, if needed, use the 
alternative Not rounded method.

3
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Fiji
Export RI Data to Excel (NOT rounded method)  Part 1 of 3

When loading a Tiff file and trying to 
export it as a text file, RI values are 
rounded and truncated to 3 digits after 
the coma. 
The way to avoid this is to multiply the RI 
values of the image by 10 before the 
Export and then to divide them by 10
in Excel.

Open the Tiff, image, Run the command 
Process> Math > Multiply (1).

In the pop-up window, insert the value
10 , then click OK (2)

The image becomes white, not visible, 
as all RI values are now multiplied by 10

3

1

2



Slide /16
®Nanolive SA

2014-2017

Fiji
Export RI Data to Excel (NOT rounded method) Part 2 of 3

From theTiff file with RI values 
multiplied 
by 10, Run the command 
File > Save as > Text Image (1) and save 
the file.

Open the text file, select all data 
(shortcut CTRL-A), copy (CTRL-C) and 
paste (CTRL-V) the text in Excel (2).

Note1: please note that the X,Y
coordinates in the image in the upper 
left 
Corner and start at 0,0.

Note2: RI values are now in the range of 
13.xxx as they have been multiplied by 
10.

3
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Fiji
Export RI Data to Excel (NOT rounded method) Part 3 of 3

In Excel, in a blank cell, enter the value
10 (1) and copy it in the clipboard
(CTRL-C).

Select all your RI values and open the 
menu with a right click on the mouse and
“Select Paste special”.
The paste special options are displayed.
Select “Divide” (2)

Click on OK, then all the selected values
are divided by the value stored in the 
Clipboard, here the value 10 (3).

Note: This method can be used also
when exporting an histogram.

1

2
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Fiji
Intensity / Colour map distribution

This operation allows to create a coloured RI distribution map with a colour scale. This helps to quickly visualize the RI distribution.  

In Fiji, Load a tiff image in grey scale.

Adjust the thresholds to remove 
unwanted values if necessary (here 
values below 1.33), Run Image > Adjust 
> threshold.

Transform the gray scale image in 
colour map by applying a LUT,  Run 
Image > Lookup tables > 16 colours (1)

Add the values scale in the upper right 
corner, Run Analyse > tools > 
calibration bar. In the pop-up window, 
enter the value 4 for the number of 
decimal places (2)

1 2
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Fiji
Examples of colour maps distribution

Thresholding done with max value: 1.39 
and a full range.

Thresholding done with max value: 1.35 
and a reduced RI range

By adjusting the threshold values, the range of RI displayed is modified and images are looking differently. Below, two examples of the same 
image with two different ranges. 
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Fiji
Extract one layer from the Exported Tiff file

Before After

1. Run the command Image > Stacks > Tools > Make Substack

This operation allows to extract one layer from the exported Tiff file that contains 96 layers and to save it as an independent file.

2. A window  “Substack Maker” appears, then indicate 
your layer reference (here 54)  and click OK

3. A new window  pops-up with the name Substack(xx), 
here xx = 54. Save the file by File > Save as > Tiff. The 
new file contains now only 1 layer.
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Fiji
Extract a selection of layers from the Exported Tiff file

Before After

1. Run the command Image > Stacks > Tools > Make Substack

This operation allows to extract several layers of interest from the exported Tiff file that contains 96 layers and to save this new stack of layers as an independent file.

2. A window  “Substack Maker” appears, then indicate 
your layer reference (here 50-55)  and click OK

3. A new window  pops-up with the name Substack(xx), 
here xx = 50-55. Save the file by File > Save as > Tiff. The 
new file contains now only 6 layers.
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Fiji
Combine RI information of a set of layers with a Z Projection

Before After

1. Create a substack with the selected tomographic layers.
2. Run the command Image > Stacks > Z Project

This operation allows to create a synthetic image by combining RI information contained in a set of  tomographic layers .

3. A window  “ZProjection” appears, then select the 
projection method (here : Max Intensity)

4. A new image MAX_Substack (50-55) is created. Adjust 
the Brightness/Contrast for a better visibility. Save the 
file by File > Save as > Tiff. 
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Fiji
Select a region of Interest for analysing data

Before After

1. Zoom in your image to improve visualization of the ROI. (SHIFT + or SHIFT- ).
2. Move the ROI by holding SHIFT and moving the mouse cursor.
3. Select the free hand tool by example

This operation allows to select a region of Interest.

4. Hold the mouse right button and draw the contour of 
your ROI.

5. Enlarge your selection if needed

6. In the “Enlarge Selection” dialog box, define the number
of pixels needed to improve the ROI. 
To remove the selection, use EDIT>Selection>Select None



Slide /26
®Nanolive SA

2014-2017

Fiji
Display RI Data histogram of a ROI

Define a ROI, Region Of Interest in the
image (1).
Run the command Analyze > Histogram 
(2)
A pop-up window histogram is showing 
up (2) to adjust histogram settings (bins, 
min, max…) (3)
Click on “OK” and the histogram is 
displayed (4).

Note1: the histogram is calculated based
on the ROI values. The count indicates 
the number of pixel information 
considered, a full image includes 262144 
pixels (512*512).

Import the histogram data in Excel 
(slide11)

Note2: Please note that this ROI is a 2D 
ROI only. 3

1

2

4
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3D Cell Explorer - Fluo
Select RI data  based on a fluo marker.

The 3D Cell Explorer-fluo is a master piece for Advanced Research activities as both RI and 
fluorescence information can be correlated.

The method hereafter describes how to use the fluo signal from marked organelles as a 
selection mask to collect RI information in a 2D RI distribution map generated by STEVE.
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 1 of 7

This operation describes how to export information from STEVE.

1

2

From STEVE, Export the RI data in a .tiff 
format. Either use the export button or 
the File> Export command.
In the Export dialog box :
Select RI Volume
Select Tiff format
Select a folder and define a filename
Click OK (1)

Note: the exported Tiff file is made of 
96 stacked  layers, one layer per STEVE 
tomographic slice.

Then, from STEVE, Export the Fluo data 
in a .tiff format. Select the appropriate 
Fluo channel to export. 
Select a folder and define a filename
Click OK (2)
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 2 of 7

Before After

1. From the Tiff image of the fluo layer, run the command 
Image> Adjust > Threshold. 

This operation allows to define precisely the ROI that will be selected by adjusting a threshold level to select or not pixels.

2. The image is becoming red where are the unselected 
pixels. In the pop-up window “Threshold” adjust the 
cursors to enlarge or narrow the number of pixels that 
will be part of the ROI.
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 3 of 7

Before After

1. From the Tiff image where a threshold has been applied, 
Run the command Edit > Selection > Create mask. 

This operation allows to create the mask from the selected pixels.

2. A new image appears, named “mask”. The black region 
are the unselected pixels, value is 255. The white 
region are the selected pixels, value is 0.

3. Close the “red” source image.
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 4 of 7

Before After

1. In the Fiji tool bar, select the “color picker” tool.

This operation allows to rework the mask to remove unwanted areas (e.g. adjacent cells).

2. Select a black zone in the mask image.
3. In the Fiji tool bar, select the “brush” tool. By a right 

click, adjust the brush size.

4. Re-paint the unwanted white areas in black.
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 5 of 7

This operation allows to define the ROI contour inside the mask image.

1. Run the command Edit > Selection > Create Selection

The borders of the ROI is highlighted in yellow now
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Correlate Refractive Index and Fluorescence information
Create a selection mask from a fluo signal Part 6 of 7

This operation allows to apply the ROI contour on the Refractive Index Image.

1. Open the Tiff file containing RI values in grey levels and 
select the appropriate layer by moving the slicer at the 
bottom of the image.
2. Adjust the Contrast and Brightness (see procedure
3. described in this presentation).
4. Click first on the mask image below to select the 
window

5. Then, Click on the RI grey levels image
6. Type SHIFT and E. The yellow contour is now applied to 
The RI grey level image.
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Correlate Refractive Index and Fluorescence information
Display RI Data Histogram

Run the command Analyze > Histogram 
(1)
A pop-up window histogram is showing 
up (2) to adjust histogram settings (bins, 
min, max…). 
Keep default values and click on “OK”, 
the histogram is displayed (3).

Note1: the histogram is calculated based
on the ROI selection. The count indicates 
the number of pixel information 
considered, a full image includes 262144 
pixels (512*512).

Import the histogram data in Excel 
(slide11)

Note2: Please note that this ROI is a 2D 
ROI only. 

1
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